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 RemoteSQLCeMobile and RemoteSQLCE.dll allow you to access SQLCe, SQL Mobile,
and SQL Everywhere databases directly from your desktop.
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Contents

Contents
RemoteSQLCeMobile allows you to manage SqlServerCE, SqlMobile and SQL 2005 Compact Edition
databases on your Pocket PC from your desktop PC. 
The program will act as a client or a server allowing you to use Activesync  or a wired or wireless
connection .

From your desktop you can
Create a database
Drop a database
Examine the database structure
Compact a database
Create a table
Drop a table
Add columns
Drop columns
Add an index
Drop an index
Run SQL queries
Execute batches of SQL statements
Load from a CSV file
Convert and/or populate from a desktop database to a SqlServerCE database
Script a database - take a SqlCE database it, and create a SQLServer database AND populate it

      Export to Excel, CSV,XML and HTML

See Connection Setting  for more details on setting up your communications or use the step by step  guide.

In addition, we provide DB Loader, which allows you to execute multiple SQL statements on your Pocket
PC. 

RemoteSQLCeMobile now automatically starts and connects the PocketPC client if the PPC is in the
cradle.

SQL 2005 Compact Edition can be downloaded here
SQL Mobile can be downloaded here
SQLServerCE can still be downloaded here

-o-
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Components
There are now 4 components to the software.

The PC component is RemoteSQLCeMobile. There are 3 components for actually accessing the
databases. On the device. there are RemoteSQLCeServer and RemoteSQLMobileServer, for the the 2
different database versions. On the PC there is SqlCEDesktopServer. Either component can act as a client
or a server. After connection, operation of the software is identical. 

SqlCEDesktop will only be enabled if it is detected on your system. The system looks for the file 
sqlceme30.dll, to be located in the C:\Program Files\Microsoft SQL Server Compact Edition\v3.1\  folder.
This can be overridden in the settings screen.

This allows you to manage a SqlServerCE database from your PC using Activesync. See PC Settings  and
Pocket PC Settings  and Connection Setting  for more details on setting up your communications.

-o-
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Connection Settings
RemoteSQLCeMobile can act as a server or a client, which can be confusing - this may help out, or try the
step by step guide .

ActiveSync

Pocket PC -         Set as a Client 
                            Port No 9891
                            HostName ppp_peer

PC -                 Set as Act as a Server
                        Port No 9891
                        Time out 1 (Minute)
                        Connect at Startup Checked

With this configuration, when you start the PC, it will immediately start to listen. Start the Pocket PC
component, and click on Connect. The 2 devices will communicate over ActiveSync. Typical read speed is
100 records per second.

Ethernet

Pocket PC -         Set as a Server
                           Port No 9891

PC -                 Act as a Client
                        Port No 9891
                        Server Name/IP IP Address of Pocket PC

Or 

Pocket PC -         Set as a Client 
                            Port No 9891
                            HostName Name/IP Address of PC

PC -                 Set as Act as a Server
                        Port No 9891
                        Time out 1 (Minute)
                        Connect at Startup Checked

                
        
                
                

-o-
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A step by step guide to connecting
If you can't connect the 2 devices, you are not going to have much success, so we will try to explain how to
connect your Pocket PC to the PC.

If your Pocket PC is in the cradle, then this  is the section for you. If you want to use an ethernet or 802.11
connection, then try this .

-o-
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Porting a database step by step
Porting a database from the PC platform to the PPC is fairly straightforward. This is a step by step guide
showing how to do it.

First of all, click on the 'SqlGenerate' icon

Next, select the TYPE of database you wish to convert from the drop down list.

In we choose an Access database, we will be prompted to browse for it and open it.

If we choose SqlServer, we click on 'OK' to get a list of SqlServer databases on our system...

Select a database from the list, and click on Get Tables

In all cases, we finish up with a list of tables.
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At this point, you can select one, many or all tables to generate.

If you wish to 'drop' the table prior to creation, check the 'Drop tables' box.
If you wish to populate your Pocket PC database, check the 'Populate' box.
If you wish to override the 'Select * from ' then you may customise the sql, check the 'Customise populate'
box.
If you wish to replace illegal characters in any field or table names (SqlServerCE is stricter on names),
check the 'Replace' box.
If you wish to rename any tables prior to the load, check the 'Rename tables...' box.

At this point, you decide whether you want to use an existing database, or create a new base .
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Finally, click on 'Generate Base'.
The software will now generate all the statments needed to generate and populate the database on the
Pocket PC.
Before this is done, you get the option to save this script file. 

Finally, you will be told how many records the generation will process, and asked if you wish to continue.
At this point, the program will generate the database on your Pocket PC, and will open the database for
you at the end of the creation.

Any errors are logged to a file, which you can view at the end.

-o-
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Using on the emulator
Although not strictly designed to run on the emulator, RemoteSQLCeMobile will run on the emulator. The
method of doing this is as follows:-

1.      Copy the supplied file RemoteSqlCeServer_PPC.X86.CAB to a shared area on your PC
2.        Using file explorer on the emulator, navigate to the folder in which you placed

RemoteSqlCeServer_PPC.X86.CAB
3.        Click and hold the left mouse button down, and select 'Copy'
4.        Navigate to the My Documents folder (or any folder you like), and select Edit>Paste
5.        Double-Click on the RemoteSqlCeServer_PPC.X86.CAB file, and it should install
6.        An Icon will be created in the Programs folder (Not a pretty Icon, granted, but an Icon)
7.        Double-Click to launch the program
8.        Click on settings, and set the program to be a client, using Port 9891, and connecting to the IP

address (or name) of the PC you          are running on.
9.        Click on OK
10.      Set the SqlCEMobileClient on the PC to listen
11.      Click on Connect on the emulator.
12.      The 2 programs should start talking to eachother, and you should be able to create and

manipulate SqlServerCE databases

Please remember - Operation on the Emulator is not fully supported, as the software is designed to
run, and was tested on a Pocket PC Device.

-o-
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PC Settings
The PC can act as a client  or a server . To change these settings, click on File>Settings

See Connection Setting  for more details on setting up your communications and Settings for further
options.

-o-

 



p14

© GUI Innovations Limited, 2006

Choosing your database version
RemoteSQLCeMobile can access SqlServerCE, SqlMobile and SqlCEDesktop databases. It will alway
start up in the mode you last used.
To change your connection, click on SqlVersion on the menu.

The version you are currently using is shown by the check mark, and also in the status bar.

To change versions, simply click on your selected version.

The icons will tell you the version of the database.

The colour of the icons mean:-
Green - the database is open
Cyan - the database is SqlServerCE or SqlCEDesktop
Magenta - the database is SqlMobile

No matter which version you use, the software will choose the correct connection for you. All databases
from your mobile device are shown together, and SqlCEDesktopcg databases are show separately.

-o-
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PC Server
This is the screen for using the PC as a Server

See Connection Setting  for more details on setting up your communications.

-o-
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PC Client
This is the screen for using the PC as a Server

See Connection Setting  for more details on setting up your communications.

-o-
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Pocket PC Settings
The main Pocket PC screen is show below. Click on a hot-spot for more details

-o-
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Pocket PC Client
The settings for the Pocket PC acting as a client. Click on a 'hot-spot' for more details

See Connection Setting  for more details on setting up your communications.

-o-
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Pocket PC Server
The settings for the Pocket PC acting as a server. Click on a 'hot-spot' for more details

See Connection Setting  for more details on setting up your communications.

-o-
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Pocket PC Icon
The application hidden - Click on the SqlCEServer Icon  in the system tray to re-activate the
application. 

-o-
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Connecting

If the PC is a client, click on File>Listen, or click on the icon 

If the PC is a server, click on File>Connect, or click on the icon 

In either case, when a connection is made, a list of databases will appear.

Double-click on a database to open it, or right-click to see options.

-o-
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Databases
Double-click on a database to open it, or right-click to see a list of options. When you open a database, you
will be prompted for a password. If your database has no password, then simply click on OK.

The colour of the icons mean:-
Green - the database is open
Cyan - the database is SqlServerCE or SqlCEDesktop
Magenta - the database is SqlMobile

Right-click on a database to see your range of options. Click on a 'hot-spot' for more details on the options.

Compacting will compact your database, and will report on any savings made. You are recommended to
compact your database on a 'timely' basis.

-o-
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Working with SqlCEDesktop
There are 2 ways of adding databases to your treeview of SqlCEDesktop databases.
You can right-click on 'DataBases', and choose open.

 

This will allow you to browse for and open a database. Alternately, you can click on the

search icon , which will search the folder you specify for any SqlCEDesktop databases. You
can search the whole hard drive to populate the list, but this may take some time.

Accessing SQLCEDesktop databases is then the same as SqlServerCE or SqlMobile
databases. The same client-server architecture is used, so we can take advantage of having
a common client for all our databases.
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Tables
This screen shows all the tables in the database, including system tables.Right-click on a table to show
your options.
Click on the Excel icon to export to Microsoft Excel.

Show all records will simply do a 'Select *' from your highlighted table.

Show first 'n' records will prompt for how many records to retrieve, and retrieve that many

Query will simply open the query window

Count records will do  'Select count(*)' from your highlighted table.

-o-
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Settings

RemoteSQLCe by default uses the pipe (|) character to separate data. You can change this
here.

When listening for a connection, you can get RemoteSQLCe to time out after n minutes.

Check the box to get RemoteSQLCe to listen/connect as soon as you start the program

You can choose how many decimal places to display in float fields.

Finally, you can choose not to be prompted for passwords.

-o-
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Totaling
When looking at your results, you can click on a numeric cell, hold the left mouse button
down, and drag the mouse. The results will automatically be totaled, as illustrated here.

-o-
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Table Layout
This shows you all the columns in the table, and their properties. Right-click to add a new column , drop a
column add a new index  or Script the table create
Click on the Excel icon to export to Microsoft Excel.

-o-
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Creating a new column
This screen is used for adding 1 or more columns to a table. Click on a hot-spot for more details.

-o-
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Indexes
This screen shows all the indexes for the chosen table. Right-click to get options. Click on a 'hot-spot' for
more details. Click on the Excel icon to export to Microsoft Excel.

-o-
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Queries
The software contains a 'query' window allowing you to do 'ad-hoc' queries. The full range of SQL queries
is supported. 'Select' queries return their results in a 'grid'. Click on a heading to sort the grid - click again
to reverse the sort order. For more details see here.

Click on the Excel icon to export to Microsoft Excel.
Click on the CSV icon to export to CSV Files
Click on the XML icon to export to XML files
Click on the HTML icon to export to HTML Files
Click on the SQL icon to generate insert statements (More Details )

Dragging the mouse across numeric columns will automatically add them up, and put the results in the
main status bar 

The query window works in a similar way to SqlQuery. You can have many lines of commands, but if you
highlight a command, only that command will be carried out, e.g.

Select * from tDepots

Update tDepots set depot_name = 'Wincanton' where depot_ref = 3

Highlighting the line 'Delete from' etc, and clicking on the 'Go' button will just do the 'Delete'

Right-click to bring up a context menu to help build queries

-o-
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Working with query results

-o-
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Creating a table
Enter your column names and properties, and click on 'add table' when you are done. Click on a 'hot-spot'
for more details.

-o-
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Creating an index
Use this screen to create indexes on your selected table. Click on a 'hot-spot' for more details.

-o-
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Database Information

The database version is supplied in the title of the frame

-o-
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Create a database
This screen allows you to create a new database. You can browse your Pocket PC file structure (including
storage cards) and choose a folder. Select a name for your database, and optionally enter a password.
Then click on 'Create' to create the database. The list of databases is automatically refreshed.
To create a new folder, right click on the folder you wish to create it in.

-o-
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Execute SQL statements
You have the ability to execute statements from a file. The file should contain 1 statement per line, as...

insert into t1 values (1,2)
insert into t1 values (2,3)
.....

The program will run to end of file executing all statements. At the end of the file, it will show you any
statements that had errors, and what the errors were.

To stop the execution, click on the red 'Stop' button on the toolbar. You may have do this several times to
get the server to listen, as it locks the screen during operations.

-o-
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Exporting data
When you have retrieved from the database, you have a choice of how to export results.
Highlight your results, and click on file. 
You can export to Excel, CSV, XML, HTML or you can export the retrieved data as insert
statements, to populate a new database.

-o-
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Generate Database
RemoteSQLCe also allows you to create a SQLServerCe database from an existing database. SqlServer,
Access and ODBC connected databases are supported.
Click on a 'hot-spot' below more details

-o-
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Customising data base population
This screen allows you to customise your database population.
The "Select * from " statement is generated, and will select all records. You can change this
to only select the records you want. RemoteSQLCe does no syntax checking, it just submits
the string to the database.

-o-
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Rename Tables
If you want different names for your CE tables, check this box. Prior to generation, you are
presented with the screen below, which will allow you to have a different name for your PPC
tables.

-o-
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Load from CSV file
Allows you to load from a CSV file. Statments are generated in the format:-

Insert into tablename (column names) values (values)

RemoteSQLCeMobile takes into account Identity columns, so, if your table is structured

Record_Key                Int                Identity
Customer_Name        nvarchar(50)
Customer_Inits                nvarchar(4)

RemoteSQLCe would expect the CSV table to be in the format

"Vickers","PAV"
"Allardyce","S"
"Djorkaeff","Y"

The insert statement would be generated as:-

Insert into customers (Customer_Name,Customer_Inits) Values ('Vickers','PAV')

etc.

The identity column can be anywhere on the record, not just the first column.

The records MUST be separated by commas. 

-o-

 



p43

© GUI Innovations Limited, 2006

DB Loader
DB Loader allows you to execute many SQL statements on your PC. For example, you could 
generate your database from a SQL Server, and when asked, save the script file, and do not
execute the statments. 

You can them copy the resulting file to your PPC and use DB Loader.

A sample script file would be...

This could come in useful if you have 1000's of records to load, and do not wish to tie up
your PC. Simply copy the script file to a memory card, and use DB Loader to execute it.

DB Loader automatically lists all the databases on your device, so just choose a database.

Then click on the browse button  or enter your file name and click on 'Go'

The system will start executing the statements and will display its progress every 100
records...

Any errors are saved to a file, and at the end, you get the chance to examine this file..
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Scripting the database
RemoteSQLCeMobile gives you 3 options to script your database
Script the Schema
Script the data 
Script Both

Simply right click on a database choose your option

 

-o-
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Script the schema
You will be prompted for your Database password. The program will then script each table in
the database, including indexes

-o-
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Script the data
This will create insert statements for all tables in your database. 

-o-
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Script schema and data
This option will script the database schema, and will the script the inserts for each table.

-o-



p49

© GUI Innovations Limited, 2006

Using your own programs on the device
Using our DLL on the device
Rather than use our interface on the Pocket PC, you may wish to use your own program, or
hide from the user that RemoteSQLCeMobile is running. 

To allow you to do this, at the request of one of our users, we also provide the PPC
component as a dll. 
This will support all operations from RemoteSQLCe and RemoteSQLCE.dll

In your compact framework application, add a reference to our dll - installed in the 
C:\Program Files\Remote SQLServer CE folder

Click on Project>Add Reference

Click on Browse and add a reference to RemoteSQLCeDll.dll for SqlServerCE databases, or
RemoteSQLMobileDll.Dll for SqlMobile devices.

You may get a warning about platform, click on OK to ignore this warning. 

Programming the DLL

-o-
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Programming the DLL
First of all import the reference, e.g.

Imports RemoteSQLCedll 
or
Imports RemoteSQLMobiledll

and then declare an instance of it as 

Private rSql As GUI_RemoteSQLCeDll

There are very few properties to set, and these are equivalent to the PPC Settings, catering
for both client and server. 

The properties are...

Act_As_A_Server (Boolean)
Act_As_A_Client (Boolean)
Remote_Port (Integer)
Host (String)

The methods are...
Init_To_Last_Values - Sets Remote_Port, Act_As_A_xxx and Host to their values from the
previous run. 
Connect_To_Server 
Listen_For_Connection

In all cases, these methods return integers. A non-zero return code is an error, and sets the
Error_Message property.

Sample code to call this is...
        Set rSql =  New GUI_RemoteSQLCeDll
        rSql.Act_As_Client = True
        rSql.Host = "ppp_peer"
        rSql.Remote_Port = 9891

        If rSql.Connect_To_Server() <> 0 Then
            MsgBox(rSql.Error_Message)
        End If

This will connect to the PC listening on the default port, via activesync. 

If the dll connects successfully, control is NOT returned to your program, so you
may wish to do this in a thread.

-o-
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RemoteSQLCe.dll
RemoteSQLCe.dll
RemoteSQLCe.dll is a com object that allows you to harness the power of RemoteSQLCe in
your own programs. Virtually everything you can do with RemoteSQLCe, you can do with
RemoteSQLCe.dll. 

This allows you to synchroncise any database with a PPC if you wish, using your own
programs.

For more details, see Methods and Properties

The sofware is provided with 2 sample programs, 1 written in VB6, and 1 written in VB.Net
just to get you started. These programs demonstrate a lot of the functionality use in
RemoteSQLCe.dll

To use the dll in VB.Net, click on Project>Add Reference
Click on the COM tab, and then click on the Browse button. Browse to RemoteSQLCe.dll
(usually found in the C:\Program Files\Remote SQLServer CE folder), and click on Open.
Finally, click on OK and the reference will be added.

To use it in your VB.Net code, at the start of the Form or Module, add at the top of the code,
Imports RemoteSQLCe

Declare an instance similar to....

Private rs as RemoteSQLCe

and finally, in your program, do
rs = New RemoteSQLCe
rs.User_Name = "Evaluation"
rs.User_Licence = 12345678
If rs.Initialise <> 0 Then ...

To use in VB6, click on Project>References
Click on the Browse button. Browse to RemoteSQLCe.dll (usually found in the C:\Program
Files\C:\Program Files\Remote SQLServer CEMobile\PC Dll\ folder), and click on Open.
Finally, click on OK and the reference will be added.

In your code, declare it as...

Private rs As RemoteSQLCe

And then when you want to use it do

Set rs = New RemoteSQLCe
rs.User_Name = "Evaluation"
rs.User_Licence = 12345678
If rs.Initialise <> 0 Then ...

-o-
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Properties
Connected
Data Type: Boolean

Returns a value to say whether the PC is connected to the Pocket PC.

Syntax: remotesql.Connected 

See also: Listen_For_Connection, Connect_To_Server

-o-
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Database_Count
Data Type: Integer

Returns a value to say how many databases were found on the Pocket PC

Syntax: remotesql.Database_Count 

See also: List_Bases

-o-
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Database_Name
Data Type: String

Returns/Sets the database name of the SQLCe database. This must include the full path.

Syntax: remotesql.Database_Name = "\My Documents\Test.sdf" 

See also: Password, Encrypt

-o-
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Databases
Data Type: Array

Returns a value to show the names of all databases found on the Pocket PC. Number of
databases are show in Database_Count

Syntax: remotesql.Databases(0) 

See also: List_Bases

-o-

 



p56

© GUI Innovations Limited, 2006

Database_Versions
Data Type: Array

Returns a value to show the versions of all databases found on the Pocket PC. Number of
databases are show in Database_Count

Syntax: remotesql.Database_Versions(0) 

See also: List_Bases

A value of 2 indicates SqlServerCE, and a value of 3 indicates SqlMobile

-o-
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Encrypt
Data Type: Boolean

Returns/Sets a value to say whether the SDF file is encrypted on the PPC

Syntax: remotesql.Encrypt = True 

See also: Open_Database

-o-
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EOF
Data Type: Boolean

Returns a value to say whether end of file has been reached following a select statment.

Syntax: remotesql.EOF 

See also: Sql, Execute

-o-
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Error_Message
Data Type: String

Returns a value showing any error message returned from an operation.

Syntax: remotesql.Error_Message 

See also

-o-
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Error_Number
Data Type: Integer

Returns a value to say whether an error was encountered during the last operation. Non-zero
is an error condition.

Syntax: remotesql.Error_Number 

See also Error_Message

-o-
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Field_Count
Data Type: Integer

Returns a value to say how many fields were retrieved by a Select statement.

Syntax: remotesql.Field_Count 

See also: Sql, Execute

Dim ict as integer
for ict = 0 to rs.Field_Count -1
  list1.additem rs.Field_Name(ict), rs.Field_Value(ict),rs.Field_Len(ict), rs.Field_Type(ict)
Next

-o-
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Field_Len
Data Type:  Integer Array

Returns a value showing the length of each field returned.

Syntax: remotesql.Field_Len(0) 

See also: Field_Count

-o-
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Field_Name
Data Type:  String Array

Returns a value showing the name of each field returned.

Syntax: remotesql.Field_Name(0) 

See also: Field_Count

-o-

 



p64

© GUI Innovations Limited, 2006

Field_Type
Data Type:  Integer Array

Returns a value showing the type of each field returned.

Syntax: remotesql.Field_Type(0) 

Values are the same as ADO constants, 

ADOX SQL Server CE data types

adSmallInt smallint

adInteger integer

adSingle real

adDouble float

adCurrency money

adBoolean bit

adUnsignedTinyInt tinyint

adBigInt bigint

adGUID uniqueidentifier

adVarBinary varbinary

adBinary binary

adVarWChar nvarchar

adWChar nchar

adNumeric numeric

adDBTimestamp datetime

adLongVarBinary image

adLongVarWChar ntext

See also: Field_Count

-o-
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Field_Value
Data Type:  Array

Returns a value showing the value of each field returned. 

Syntax: remotesql.Field_Value(0) 

See also: Field_Count

-o-
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Host_Name
Data Type:  String 

Returns/Sets a value showing the name or ip address of the host.

Syntax: remotesql.Host_Name

See also: Connect_To_Server

-o-
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Info_Message
Data Type:  String 

Returns a value showing an informatry message after operations like creating or
compressing a database.

Syntax: remotesql.Info_Message

See also: Create_Database, Compress_Database
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Password
Data Type:  String 

Returns/Sets a value for the password when opening/creating a database.

Syntax: remotesql.Password 

See also: Open_Database, Create_Database
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Port_Number
Data Type:  Long

Returns/Sets a value for the port number to connect to the PPC on. Default port is 9891

Syntax: remotesql.Port_Number

See also: Listen_For_Connection, Connect_To_Server
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Records
Data Type:  Long

Returns a value showing the number of records affected by the last operation.

Syntax: remotesql.Records

See also: Sql, Execute
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Returned_Data
Data Type:  String 

Returns a value of all the fields returned separated by the pipe (|) character. This can be
used as an alternative to using Field_Value

Syntax: remotesql.Returned_Data

See also Field_Value
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Separator
Data Type:  String 

Returns/Sets a value of the separator RemoteSQLCe uses. The default is the pipe | character

Syntax: remotesql.separator = "^"

This must be set prior to any retrievals. Suggestion is to set it as soon as you initialise, and
BEFORE you connect

-o-
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Sql
Data Type:  String 

Returns/Sets a value of the sql string you wish to excute. 

Syntax: remotesql.Sql = "Select * from tDepots"

See also: Execute

-o-
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Table_Count
Data Type:  Long

Returns a value showing how many tables are in the data base. This includes system tables.

Syntax: remotesql.Table_Count

See also: List_Tables

-o-
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Tables
Data Type:  String Array

Returns a value showing the names of all tables in the database.

Syntax: remotesql.Tables(0)

See also: List_Tables
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Table_Type
Data Type:  String Array

Returns a value showing the type of each table returned. Values are "TABLE" or "SYSTEM
TABLE"

Syntax: remotesql.Table_Type(0) 

See also: List_Tables

-o-
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Timeout
Data Type:  Long

Returns/Sets a value in milliseconds telling the program to time out on listening after 
Timeout milliseconds. A value of 0 means do not time out

Syntax: remotesql.Timeout

See also: Listen_For_Connection
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User_Licence
Data Type:  Double

Returns/Sets a value for the user licence. This is sent to you when you purchase the DLL. It
is NOT the same as your licence number for RemoteSQLCe for Pocket PC. Must be used to
initialise the DLL.

Syntax: remotesql.User_Licence

See also: Initialise, User_Name

-o-
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User_Name
Data Type:  String 

Returns/Sets a value showing the user name. This is used in conjunction with User_Licence
for initalising the dll.

Syntax: remotesql.User_Name

See also: Initialise, User_Licence

-o-
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Version_Number
Data Type:  String 

Returns a value showing the version number of the DLL. You may be asked for this if you
have a problem.

Syntax: remotesql.Version_Number

See also

-o-
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Methods
Close_Connection
Closes the connection to the Pocket PC and also closes the database.

Syntax: remotesql.Close_Connection

See also: Listen_For_Connection, Connect_To_Server
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CloseDown
Closes the dll for anymore access - should be called when the calling program is terminating.

Syntax: remotesql.CloseDown

-o-
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Close_Database
Closes the the database on the Pocket PC without closing the connection

Syntax: remotesql.Close_Database

See also: Open_Database
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Compress_Database
Compresses the current open database. Returns and Info_Message telling you how many
bytes were saved.

Syntax: remotesql.Compress_Database

See also

-o-
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Connect_To_Server
Connect to the Pocket PC when the Pocket PC is functioning as a server. Needs the 
Host_Name of the Pocket PC and the Port_Number

Please see A step by step guide to connecting for more details

Syntax: remotesql.Connect_To_Server

See also: 

-o-
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Create_Database
Creates a new database on the Pocket PC. Requires Database_Name, Password and Encrypt
to be set

Syntax: remotesql.Close_Connection

See also Database_Name, Password and Encrypt
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Drop_Database
Drops a database on the Pocket PC. Requires Database_Name to be set

Syntax: remotesql.Drop_Database

See also Database_Name

-o-
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Execute
Execute a SQL string. This can be a 'Select' statement or a statement that does not return a
record, such as 'Insert'. Records shows how many records have been affected by the
command.

Syntax: remotesql.Execute

To read records, you can do similar to...

    rs.Sql = "Select * from tdepots"
    rs.Execute
    While Not rs.EOF
        lstRecords.AddItem rs.Returned_Data
        rs.MoveNext
    Wend  

See also: Sql, Field_Count

-o-
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Initialise
Initialises the DLL prior to use. Requires User_Name and User_Licence setting. For
demonstration, use 'Evaluation' and 12345678 for these values. If the dll has not been
initialised, then nothing will function. 

When running as an evaluation version, message boxes appear after opening, reading etc.

Syntax: remotesql.Initialise

-o-
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List_Bases
Lists all the databases found on the Pocket PC. Values affected are Database_Count and
Databases

Syntax: remotesql.List_Bases

See also: Databases, Database_Count

-o-
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List_Tables
Lists all the tables on the currently opened database. Values affected are Table_Count,
Table_Type and Tables

Syntax: remotesql.List_Tables

See also: Table_Count, Table_Type and Tables
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Listen_For_Connection
Puts the PC into 'Listen' mode, to listen for a connection from the Pocket PC. Needs the the 
Port_Number

Please see A step by step guide to connecting for more details

Syntax: remotesql.Listen_For_Connection

See also: Port_Number, Timeout

-o-
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Movenext
Moves to the next record in the recordset.

Syntax: remotesql.Movenext

See also: Execute, Sql
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Open_Database
Opens the the database on the Pocket PC. Needs a full path to the database (e.g. \My
Documents\Mydb.sdf) in Database_Name and optionally a Password and Encrypt

Syntax: remotesql.Open_Database

See also: Close_Database, Close_Connection

-o-
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VB.Net Demo Program
VB.Net Code
Click on a hot spot to see the code behind the program, and see how simple it is to
program...

-o-
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